Game doesn't start (white screen)

Bug reports go here

Game doesn't start (white screen)

Postby marcowy » Mon Oct 30, 2017 10:42 pm

Hi!

First of all I'd like to say I love your game very much :) I bought it on Steam on summer last year and played it a lot (I have to admit that I played it before :oops: )
Anyway I hadn't play it for a couple of months, and when I wanted to run it yestarday after last update (1.2.6), it didn't run. It is freezing a moment after launch it from Steam and it's just a window filled with white color. I had similar problem before last update, but starting it from the exe file instead of running it directly from Steam helped. Now it doesn't :( It has something common with Steam version, because the same version from GOG runs flawlessly (got it from torrent just for test). Also Steam vista-xp version works, but it looks outdated (I assume it because of the version number = 1.2.4.4).

I'd really like to play it again, after those great addons/changes/bugfixes you've made :roll:
Attachments
curious expedition white screen.jpg
curious expedition white screen.jpg (35.26 KiB) Viewed 140 times
marcowy
 
Posts: 5
Joined: Mon Oct 30, 2017 10:18 pm

Re: Game doesn't start (white screen)

Postby Ole » Wed Nov 01, 2017 11:22 am

Can you give me some extra information about what OS you are running for example?
I'll looking into it.
Ole
Curious Dev
Curious Dev
 
Posts: 30
Joined: Mon Oct 02, 2017 9:55 am

Re: Game doesn't start (white screen)

Postby marcowy » Wed Nov 01, 2017 12:38 pm

Windows 7 Ultimate SP1 32-bit
marcowy
 
Posts: 5
Joined: Mon Oct 30, 2017 10:18 pm

Re: Game doesn't start (white screen)

Postby Ole » Wed Nov 01, 2017 5:25 pm

Thank you.

We just added a "-console" option to the game. If you add that to the start options on Steam the game should start with a small console on the right side.
If you could copy and paste the text inside it here that would be amazingly helpful.

Hope we can fix this soon together.
Ole
Curious Dev
Curious Dev
 
Posts: 30
Joined: Mon Oct 02, 2017 9:55 am

Re: Game doesn't start (white screen)

Postby marcowy » Wed Nov 01, 2017 5:52 pm

Not allowed to load local resource: file:///D:/giery/# steam\steamapps\common\The Curious Expedition\resources\app.asar/play-electron.html
marcowy
 
Posts: 5
Joined: Mon Oct 30, 2017 10:18 pm

Re: Game doesn't start (white screen)

Postby marcowy » Wed Nov 01, 2017 9:29 pm

I've found what was causing the problem. My Steam folder pathname, which has # in it. I moved my Steam installation from "# steam" to just plain "steam", following this instruction https://support.steampowered.com/kb_art ... -YUBN-8129
Now CE starts perfectly :)

Although there is one new error which I see in the console, but don't know what impact it has on the game:
Error: ENOENT: no such file or directory, open 'D:\giery\Steam\steamapps\common\The Curious Expedition\langs\en\tce_texts.csv'
at Error (native)
at Object.fs.openSync (fs.js:584:18)
at Object.module.(anonymous function) [as openSync] (ATOM_SHELL_ASAR.js:159:20)
at Object.fs.readFileSync (fs.js:431:33)
at Object.fs.readFileSync (ATOM_SHELL_ASAR.js:427:29)
at b.loadLang (file:///D:/giery/Steam/steamapps/common/The%20Curious%20Expedition/resources/app.asar/min-cegame.js:1140:277)
at b.setupLang (file:///D:/giery/Steam/steamapps/common/The%20Curious%20Expedition/resources/app.asar/min-cegame.js:1140:89)
at new b (file:///D:/giery/Steam/steamapps/common/The%20Curious%20Expedition/resources/app.asar/min-cegame.js:1028:304)
at undefined.window.onload (file:///D:/giery/Steam/steamapps/common/The%20Curious%20Expedition/resources/app.asar/min-cegame.js:1146:237)
marcowy
 
Posts: 5
Joined: Mon Oct 30, 2017 10:18 pm

Re: Game doesn't start (white screen)

Postby Ole » Thu Nov 02, 2017 8:02 am

Just saw on Steam that you figured it out and was like:
"Great someone on our forums had the same problem, now I can help" :D

Glad you figured it out.
I'm still now sure why that's causing issues, but I'll try to at least show an error screen, rather than just letting you stare at a white screen.
Ole
Curious Dev
Curious Dev
 
Posts: 30
Joined: Mon Oct 02, 2017 9:55 am

Re: Game doesn't start (white screen)

Postby marcowy » Thu Nov 02, 2017 8:11 am

:lol:

Thank YOU, because the error message gave me a hint to figure it out.

And what about that other error (tce_texts.csv not found)? Is it sth. I shouldn't bothered?
marcowy
 
Posts: 5
Joined: Mon Oct 30, 2017 10:18 pm

Re: Game doesn't start (white screen)

Postby Ole » Thu Nov 02, 2017 9:19 am

Yeah, that's absolutely fine.
The error happens because it tries to load the translations files from the file system first before using the one shipped with the game. It's so translators can test their translations before uploading them.
Ole
Curious Dev
Curious Dev
 
Posts: 30
Joined: Mon Oct 02, 2017 9:55 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 3 guests
cron